LifterLMS System Requirements

Overview

# Top

LifterLMS (and all LifterLMS add-ons) are WordPress plugins and, as such, require a WordPress installation to function.

LifterLMS has no additional requirements other than those required to run WordPress. WordPress system requirements can be found at https://wordpress.org/about/requirements/.

Recommended Minimum Versions

# Top
  • WordPress version 5.5
  • PHP 7.4
  • MySQL 5.6 or greater or MariaDB 10.1 or greater
  • Nginx or Apache with mod_rewrite module

Supported Versions

# Top

LifteLMS supports all PHP versions receiving active and security support and the five most recent major WordPress releases.

 

Upgrading PHP and Databases

# Top

Depending on your hosting provider, the process to upgrade PHP and your database may differ. Some hosts provide you with a self-service upgrade, some will upgrade you automatically, while others require you to open a support request.

Check your hosts documentation to see if you can upgrade yourself.

Looking for a hosting provider for your LifterLMS-powered website?

See our list of recommended webhosts and make sure you review our comprehensive guide to hosting to help you make an informed choice.

Last Updated on
Was this article helpful?